Die-Frickler.org

Wir haben Zweigstellen in jeder Nervenheilanstalt!



16kJ, 1,4kV – Eine neue Capbank ensteht

Keine Antwort

Hallo,

am 15. Februar 2011 fiel der Startschuss zu einem gigantischen Projekt.
An diesem Tag waren ca. 90% der Materialien sind eingekauft.
120 Elkos 350V 2200µF
Holz für ein schönes Zuhause der Elektronik
Plexiglas für den Fingerschutz, damit man zum einen die Elektronik sehen kann, aber nicht dran patschen kann.
Pneumatik Material war geordert und zum Teil noch auf dem Weg.
Alu für die Verbindung der Elkos war zum Teil schon lange vorher gekauft, sollte sich aber während der Bauphase rausstellen, dass es nicht 100% geeignet war.

Einleitung:
Im Bau befindet sich eine noch größere Cpabank als sie von diversen Treffen bekannte Bank:

[youtube]F45xdpbolek[/youtube]
Pierbach im April 2010. Es war gigantisch. Dabei waren das grad mal 8kJ.

Nun stand der Sprung auf die 2 Stelligen kJ Bereich bevor. Vorplanungszeit betrug etwa 2 Jahre. Damals wurde ein günstiges Angebot von 2200µF 350V Elkos auf eBay gefunden. Schnell war ich mit dem Verkäufer im Geschäft und ein paar Tage später kamen 100 Elkos bei mir an. 20 weitere Elkos wurde auf einem späteren Treffen dazugekauft. In der Planungsphase war schnell ein Trend erkennbar: Es sollte auf eine Modulbauweise hinauslaufen. Es wurde eine kleine Liste mit Pro und Kontra Modulbauweise – Alles miteinander Verschraubt erstellt. Hier ein Auszug: Modulbauweise: Flexibel. Ist nicht immer auf volle Energie angewiesen, kann auch mal mit nur der Hälfte fahren. Zudem ist der Transport leichter. Alles fest Verschraubt: keine unötigen Leitungen die auf eine Sammelstelle kommen, kompakte Bauweise, wenig Stellfläche. Die Pros des einen können als Kontras des Anderen gesehen werden. Letzen Endes hat mich die Modulbauweise überzeugt, da das Argument mit geringerer Energie aber voller Spannung zu arbeiten zusagte. So entstand der Plan von 6 Modulen mit jeweils 20 Elkos. Immer 4 Stück in Reihe und davon dann 5 Stück parallel. Damit standen die Daten für ein Modul fest: 1,4kV ca. 2,7kJ.

Die Steuerung:
Wer die 8kJ Bank kennt, wir sicher wissen, dass ich für die Steuerung und Ladung über die Hälfte des Platzes der Bank verwendet habe. Nicht umsonst. Auf den 2 Ebenen auf denen sich diese verteilt findet zum einen der Ladeteil Platz, zum anderen aber auch Notaus und ein sicheres Entladen über einen Widerstand.
Nun da ich jetzt eine Modulbauweise plane, kann ich nicht in Ebenen bauen. Jetzt kommt eine große Kiste zum Einsatz. Die Abmessungen betragen 40cmx40cm und die Höhe ca. 25cm.
In ihr finden sowohl Steuerung, Ladeteil als auch Notaus uns Widerstandsentladung Platz.


Ein Bild wie es in der Kiste später mal aussehen wird. Noch ist das Holz nur zusammengestellt und die einzelnen Teile hineingelegt. Oben Links findet der Notaus seinen Platz. Links die 4 Halogenlampen symbolisieren den Entlader. Später werden es 24 Lampen sein. Belastbarkeit von jeder 500W. Die einzelne Lampe quer stellt den 230V „Vorlader“ dar. Dieser soll den MOT beim Laden im unteren Spannungsbereich entladen. Da ein MOT bei geringer Spannung sehr wenig Leistung hat. Die Lampe ist hier nur ein Begrenzungswiderstand, damit der Strom nicht zu hoch wird. Unten in der Mitte ist der MOT zu sehen, darüber der Kondensator zum Resonanzladen. Ohne dauert es ewig und es geht so gut wie nix voran. Auf der rechten Seite unten ist die Spannungsversorgung für die Relais, die Steuerung und Pneumatik zu sehen. Darüber ist ein kleiner schwarzer Trafo, der für die Auswertung der Spannung an der Bank den Strom liefert. Galvanische Trennung vom Rest der Steuerung ganz wichtig, da der MOT ein Erdpotenzial herstellt und ich nicht genau weiß, wie die andere Stromversorgung auf eine „doppelte“ Erdung reagiert. Oben rechts erkennt man, die Pneumatikinsel.

Die Elektronik:
Hier wurde recht lange in der Planungsphase umgeändert und neu gestaltet. Am Schluss sollte ganz was anderes dabei rauskommen, als am Ender der Planungsphase fest stand. Am 15.2. wollte ich diese Steuerung bauen: Es sollte eine Steuerung entstehen, die sowohl die Steuerung erster Generation, als auch 2ter Generation vereint. Ein völlig neues Ansteuerungskonzept ist somit entstanden. In der kompletten Steuerung werden nicht wie früher 2 oder gar kein µC zum Einsatz kommen, sondern gleich 3 Stück. 2 werden ihr neues Zuhause in der Kiste finden, der dritte im Bedienteil.
Warum gleich 3? Im Bedienteil der stellt mir schöne Funktionen wie Spannungseinstellung und Energieeinstellung (Kapazität muss dabei vorher Eingestellt werden) zur Verfügung. Während des Ladens wird mir die soll und ist Spannung angezeigt, sowie die soll und ist Energie. In der Kiste selber nimmt der erste µC die Daten vom µC im Bedienteil auf. Speziell die Spannungs Werte und leitet diese dann weiter an den dritten µC. Der erste µC in der Kiste ist aber nicht nur dafür vorgesehen, er überwacht ständig die Druckluft, sorgt dafür, dass die Ventilatoren nicht zu viel Wind machen, wenn man sie nicht braucht und stellt fest, ob der Benutzer der Bank überhaupt diese Bedienen darf. Der zweite µC in der Kiste ist ein armer Hundling. Er ist von allem Isoliert. Hat seine eigene Stromversorgung und wenn er was von den anderen will oder bekommt, dann auch nur über Optokoppler. Dafür hat er aber auch die wertvolle Aufgabe, mir zu sagen wie viel Spannung in der Bank jetzt steckt. Rechtzeitig den Ladevorgang abzuschalten, sowie das Umschalten vom Vorlader auf den MOT.
So und wo ist da jetzt der Teil der Steuerung der zweiten Generation enthalten? Ist doch alles reine µC Sache und somit erste Generation. Nein, der kommt jetzt. Nachdem an die Bank sämtliche Daten, naja, nur die Spannung übermittel wurde, sagt der µC im Bedienteil, okay, jetzt darfst du Tasterdrücken, und aktiviert diese. Nun ist die Bank über Taster direkt Steuerbar. Und mit direkt mein ich auch direkt, kein µC kann dort rein pfuschen, nur der µC im Bedienteil kann sagen, dass jetzt Schluss ist und diese deaktivieren. Aber sämtliche Steuerbefehle laufen über direkte Leitungen zur Bank und werden dort auch so verarbeitet. Darum auch so viele Relais. Auf dem Bild ist aber nur die Hälfte zu sehen. Die andere Hälfte kommt als Sandwich oben drüber.

Termine:
Geplante Fertigstellung sollte Ende März sein. Bis dahin sollte die Kiste soweit fertig sein, dass sie zwar noch am Oszi/Messgerät läuft, aber selbständig in der Lage zu Arbeiten. 2 Wochen später (Mitte April) sollte sie dann soweit sein, dass man sie in der Öffentlichkeit vorführen kann. Das heißt, dass alles zu 100% geht, es keine Fehler mehr gibt und kein Menschliches eingreifen mehr nötig ist um irgendwelche Funktionen zu erreichen, die eigentlich automatisch gehen sollten.

Maximum und Auslegung der Steuerung:
Da bis dahin schon die Entwicklung der Programme für die Prozessoren begonnen hatte, war eine Grenze festgelegt. Kapazitätstechnisch sind 9F (Farad) möglich. Effektiv aber nur 99mF da sonst die Energie zu groß würde und auf dem Display nicht mehr richtig angezeigt werden kann. Spannungsmäßig liegt die Grenze beim Entladewiderstand. Dieser ist mit seinen 24 Lampen auf 1,4kV dimensioniert. Könnte aber jederzeit erweitert werden. Auch der geplante Thyristor der die Spannung auf die Lampen schaltet ist mit 1,6kV am Ende seiner Grenzen. Mit dem Rest können leicht bis zu 4kV gefahren werden.

Baubericht:
16. Februar:
Das erste Modul ist fertig:

Die Kiste wurde mitlerweile auch zuammengeschraubt. (Der erste Anblick von ihr war irgendwie schon so: „UFFFFFF…. Das wird riesig“)

19. Februar:
Der Entladewiderstand war fertig. Im späteren Verlauf des ganzen Baus sollte sich aber herausstellen, dass dieser Aufbau mistig ist und durch einen anderen ersetzt werden musste:


Hier ein Bild vom Test an 230V. Unter dem Terminal kann man die Holzkiste sehen. Die 10mm dicke Plexiglasplatte wurde auch schon eingepasst (eine Staubige Angelegenheit, die man nach 2h immer noch im Hals merkt)

25. Februar:
An der Uni sind alle Klausuren geschrieben. Die nächsten 2-3 Wochen konnte ich also komplett dem Projekt widmen.
Ich fing auch gleich schon mit der Einrichtung der Kiste an:


HV Gleichrichter + Resonanzkondensator für den MOT (rechts). Im Hintergrund die Relaisbank + 230V Verteilung


Umschalter für 230V Lader und MOT (oben) darunter Trenner für Ladeteil von Kondensatoren.


Zentral: Trafo für die 5V Versorgung der Schaltung, hinten links: Spannungsversorgung für den Rest der Steuerung. Rechts leicht zu sehen: Pneumatikinsel. Leitungen links: 230V Zuleitung.


Relais und 230V Verteilung.

8. März
Nach einer Längeren Pause, in der ich Basteltechnisch nicht so aktiv war, aber mir nochmal die Steuerung durch den Kopf gehen ließ um festzustellen, dass eventuell eine Kaskade besser geeignet ist. Gleichzeitig wurde auch weiteres Material beschafft u. A. für die Kaskade.
Der MOT wurde nun durch eine Kaskade ersetzt. Damit war es möglich eine große Menge an Gewicht einzusparen. (Die Kiste war schon im leeren Zustand recht schwer)

Ein erster Test der Komponenten. Die Spannung auf dem Multimeter zeigt die Hälfte der Spannung in den Kondensatoren an. Musste ich so machen, da das Multimeter „nur“ bis 1000V messen kann.

10. März:
Geschafft! Die Arbeiten die Dreckmachen sind erledigt. Nun sollte der entspannende Teil kommen. Kabelziehen in der Kiste, das Bedienteil fertig stellen. Sache von einer Woche. Somit schneller als geplant.
Hier ein paar Bilder von der Kiste:

Drecksarbeit war es, die Plexiglasplatte zu bohren. Über 2 Stunden habe ich danach die Werkstatt saugen dürfen. Das Plexiglas macht einen teuflischen Dreck. Hat sich ständig unter meine Schuhe geheftet und dort gelöst wo gesaugt war. Ständig habe ich den Dreck von a nach b und wieder nach c getragen.

12. März:
Endlich dich Sicherheit: Alle Klausuren an der Uni sind geschafft. Ich kann mich vollkommen mit dem Projekt beschäftigen. Vor Freude wurde die komplette Elektronik über den Haufen geworfen. Nein nein, die Kiste bleibt so wie sie ist. Lediglich der Teil der noch kommen sollte. Irgendwie kam es mir von Anfang an utopisch vor, 3 µCs einzubauen. einfach Overkill. Also wurde kurzerhand der Rotstift angesetzt und alle 3 µCs gestrichen. Alles durch eine Relais Logik ersetzt. Die Spannungsüberwachung übernimmt wieder ein OpAmp. Eigentlich die Steuerung von der 2. Generation. 2 Stunden später war dann die Platine auch schon gelötet:

13. März
Das Bedienteil wurde fertiggestellt.
Die Logik die darin steckt beschränkt sich auf 5 Relais und 1 Diode. Für die Dioden noch Vorwiderstände. Mehr nicht.

15. März
1 Monat ist seit dem Startschuss vergangen. Es sollte der schrecklichste Tag in der Baugeschichte werden.
An diesem Tag wurden 2 Schritte nach vorne gemacht, aber am Abend stand fest, dass es 10 zurück waren.
Die Steuerplatine wurde eingebaut, alles verkabelt. Das 15m lange Steuerkabel wurde fertig gelötet. Und es stand der erste Test an.
Es wurde alles vorbereitet, damit die 230V das erste Mal in die Leitungen fließen konnten. Ein letzter Check ob alles passt und der Stecker kam in die Dose. Die Überraschung war groß. Es hat sich nichts getan. Messgeräte haben auch nichts angezeigt. Nur das eine. 5V. Wenigstens etwas. Der erste Verdacht war, dass das Netzteil kaputt sei. (Wäre ja auch kein Wunder ist ja von Pollin) Trotzdem wurde nach einer Lösung gegoogelt. Schnell stellte sich heraus, dass das Netzteil von 5V nach einer Klemme eine Brücke haben will, damit es die 12V und 24V freischaltet. Die soll es bekommen. 5min später war die Brücke gesetzt und es konnte mit dem Test weiter gehen. Die Taster wurde getestet ob alles richtig schaltet. Blöd ist nur, dass diese weißen Relais der Meinung sind, dass sie nur in eine Richtung den Strom durchlassen müssen, in der anderen keinen Muxer machen. Also wurden diese „umgedreht“ und schon ging alles perfekt. Die 230V wurden wieder abgeklemmt und die Brücken für den Ladeteil eingesetzt. (Bis hier hin war Schritt 2) Nun wieder alles bestaften. Fürs erste laden alles vorbereiten und START. Öhhh… warum tut sich da nix? Sofort Strom weg und gesucht wo der Fehler liegt. Schnell gefunden. Der Pneumatikzylinder der die Trennung zwischen Ladeteil und Elkos übernimmt war nicht richtig angeschlossen. Das Teil wurde dann von Hand richtig eingestellt. Dabei hat es einen Schepperer getan, den meine Ohren nach 1 Stunde immer noch mit einem Pfeifen kommentierten. Nach der Schocksekunde und weiteren 10 Sekunden wurde mir klar was passiert war: Die Kaskade hatte sich vollgeladen und nun ihre Energie in die Kondensatoren geblasen. Na gut alles klar jetzt noch mal 230V drauf und alles fürs Laden vorbereitet. Na toll da tut sich gar nichts. Aber die Kaskade hat doch schon mal getan. Ja, da waren auch noch alle Dioden heil jetzt waren 2 Stück kaputt. Die 2 ersetzt (SMD Dinger, an einer Stelle die nur schwer zugänglich war, ½h später trotzdem ersetzt) Danach konnte ich richtig aufladen. Potis richtig eingestellt alles lief perfekt. Dann wurde der Entladeteil getestet. Einmal und dann nie wieder. Den Thyristor hat‘s erwischt. Seit dem leitet er nur noch. Zeit fürs Bett. Ich mag nimmer.

17. März
Ermutigt durch einen ruhigen Schlaf in der Nacht ging ich ans Werk. Der Thyristor wurde durch einen pneumatischen Schalter ersetzt. Und nachmittags konnte der Test fortgesetzt werden. Mittags habe ich noch den Notaus fertig angeschlossen. Der Test wurde erneut eingeleitet. Alle Taster getestet, nach dem alles positiv verlief konnte mit dem Laden begonnen werden. Irgendwas war sehr merkwürdig. Was genau alles passiert ist, kann ich nicht sagen. Optisch gab es 3 Dinge: Das Multimeter zeigte nicht das an was ich mir erhoffte, ein Widerstand in der Schaltung rauchte, ein Blitz setzte dem ganzen ein Ende. Akustisch quittierten meine Ohren das ganze wieder mit einem 1 stündigem Pfeifen. Schluss. Ich will nicht mehr. Soll doch ein anderer weiter machen.

Projekt eingestellt.

18. März
Ich gebe nicht auf. Was war das? Seit in der Früh war ich am Fehler suchen. Was ist da passiert und warum? Zur Mittagszeit stand dann der Bericht fest:
Eine unglückliche Verkettung von mehreren Fehlern/Störungen führte zu der Katastrophe.
Hauptfehlerquelle ist vermutlich der Notausschalter, um genau zu sein dessen Hilfskontakt. Dieser Schaltet die 24V und damit die komplette Steuerung mit Strom ein. Aufgrund eines Bautechnischen Fehlers lag dieser Hilfskontakt mit dem Pluspol der Kondensatoren zusammen. Draus resultierend waren 2 Spannungsquellen, die 24V und die Ladequelle der Kondensatoren parallel Geschaltet. Jedoch über einen 220k Widerstand. Dieser hat nun nur noch einen Widerstand von 48kOhm. Dazu kommt nun noch eine kalte Lötstelle, die dann ihren Kontakt aufgrund der hohen Verlustleistung des Widerstands aufschmolz. Da zu diesem Zeitpunkt die Spannung aber bereits so hoch war, kam es zu einem kleinen Lichtbogen, der dazu führte, dass direkt unter der Steuerung HV Masse, HV Plus, und Elektronik Masse verbunden wurden. Dies führte zum Ausfall der Spannungsversorgung, worauf die Steuerung ausfiel, Notaus rein klatschte und Ruhe war.
Aufgrund des Zusammenführens von HV Plus über die 24V Spannung auf Elektronik Masse wurde diese soweit angehoben, dass die Regelung nicht mehr gegriffen hat. Und somit die Spannung, obwohl sie nur auf ca. 30V eingestellt war auf ca. 1000V geladen hat. (Dann passierte der GAU)
Der Operationsverstärker hat seinen Geist aufgegeben, da durch den Lichtbogen die Masse angehoben wurde, die 24V auch aufgeschnellt sind, aber die 12V zurückgeblieben sind, und nicht mitgegangen ist. Somit kam es zu einer Umpolung der 12V. wie weit runter die 12V dann gesunken sind weiß ich nicht, aber für den Typ von Operationsverstärker kann ich selber sagen, dass er nach einem Peak von ca. -20V immer noch funktionierte (Andere Schaltung, Versehentlich Plus und Minus vertauscht)

Der Zeitverlust beträgt ca. 3 Tage. Weitere 2 Tage werde ich warten müssen, bis ich den nächsten Test durchführen kann. Dazu kommt noch, dass sich an  diesem Tag mein Lager mit neuem Material füllte. Doch leider musste es liegen bleiben, da die Steuerung nicht fertig war und ein weiterbau nicht möglich war.

23. März.
Neues Material für die Platine ist eingetroffen und auch schon verlötet und zusammengebaut. Die neue Steuerung wurde sofort eingebaut und mit einem erneuten Test begonnen. Die Fehler wurden auch behoben.

24. März
Elektronik ist fertig eingebaut. Verkabelung sauber verlegt. Nun stand der erste Test an. 230V wurden wieder angelegt und der erste Abgleich der Platine gemacht. Potis eingestellt (Hysterese der Ladeschaltung, Maximale Ladespannung, Drehspulinstrument, Entladespannung), Kontakte richtig hingebogen (die Pneumatikrelais zuckten noch ein bisschen wild vor sich hin). Eigentlich ein langweiliger Tag. Kostet recht viel Zeit bis alles passt.

26. März
[youtube]d43V53dU1GM[/youtube]
Fertig! Die Kiste ist nun fertig. Ein Test aller Komponenten. 1. Test: Laden bis ca. 1000V danach auf 1400V. 2. Test: Entladen über Widerstand. Erneutes Laden auf 1,4kV. 3. Test: Notaus. Alle drei Tests bestanden.

27. März
Nun galt es sich den Modulen zu widmen. Es galt 240 Löcher zu bohren, zu entgraten und genauso viele Schrauben zu verschrauben. Am Ende des Tages war es aber geschafft:

Geschrieben von michael @die-frickler.org

am 28. März 2011 um 21:55 Uhr

Antwort schreiben